package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1}[A-Z]{1}-[A-Z]{1}[0,2,4,6,8]{4}-[1-9]{1}[0-2]{0,1}`)
var str = `1A-B1234-19
1A-B0204-12
1A-B0204-c
11-B0204-12
1A-B2228-0
1A-B2228-1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}