$re = '/\d{1}[A-Z]{1}-[A-Z]{1}[0,2,4,6,8]{4}-[1-9]{1}[0-2]{0,1}/m';
$str = '1A-B1234-19
1A-B0204-12
1A-B0204-c
11-B0204-12
1A-B2228-0
1A-B2228-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);