import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1}[A-Z]{1}-[A-Z]{1}[0,2,4,6,8]{4}-[1-9]{1}[0-2]{0,1}";
final String string = "1A-B1234-19\n"
+ "1A-B0204-12\n"
+ "1A-B0204-c\n"
+ "11-B0204-12\n"
+ "1A-B2228-0\n"
+ "1A-B2228-1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}