#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\/\/)[A-Za-z0-9][A-Za-z0-9\/]*$"
Local $sString = "go" & @CRLF & _
"go2/api/hello" & @CRLF & _
"go/api45" & @CRLF & _
"/go" & @CRLF & _
"go//api" & @CRLF & _
"go/api%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")