$re = '/^(?!.*\/\/)[A-Za-z0-9][A-Za-z0-9\/]*$/m';
$str = 'go
go2/api/hello
go/api45
/go
go//api
go/api%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);