using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\/\/)[A-Za-z0-9][A-Za-z0-9\/]*$";
string input = @"go
go2/api/hello
go/api45
/go
go//api
go/api%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}