re = /^(?!.*\/\/)[A-Za-z0-9][A-Za-z0-9\/]*$/m
str = 'go
go2/api/hello
go/api45
/go
go//api
go/api%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end