package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|[[:space:]]+)\(?[Oo.'>xX-](?:_*|[.o]+)[-Xx<'.oO]\'?\)?(?:$|[[:space:]]+)`)
var str = `-________-'`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}