re = /(?:^|[[:space:]]+)\(?[Oo.'>xX-](?:_*|[.o]+)[-Xx<'.oO]\'?\)?(?:$|[[:space:]]+)/
str = '-________-\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end