using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/([^\/]+)(\/)([^\/]+)";
string substitution = @"$1=$3&";
string input = @"/s/new/v/123/c/42";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}