$re = '/\/([^\/]+)(\/)([^\/]+)/';
$str = '/s/new/v/123/c/42';
$subst = "$1=$3&";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;