const regex = /\/([^\/]+)(\/)([^\/]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/([^\\\/]+)(\\\/)([^\\\/]+)', 'g')
const str = `/s/new/v/123/c/42`;
const subst = `$1=$3&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);