re = /\/([^\/]+)(\/)([^\/]+)/
str = '/s/new/v/123/c/42'
subst = '$1=$3&'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result