import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#([0-9A-Fa-f])([0-9A-Fa-f])((?=\\2)\\1|(?:\\1\\2){2})\\b";
final String string = "#EEEEEE\n"
+ "#AAA\n"
+ "#EFE\n"
+ "#333333\n"
+ "#00006d\n"
+ "#123456\n"
+ "#ABABAB";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}