re = /#([0-9A-Fa-f])([0-9A-Fa-f])((?=\2)\1|(?:\1\2){2})\b/
str = '#EEEEEE
#AAA
#EFE
#333333
#00006d
#123456
#ABABAB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end