const regex = /#([0-9A-Fa-f])([0-9A-Fa-f])((?=\2)\1|(?:\1\2){2})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#([0-9A-Fa-f])([0-9A-Fa-f])((?=\\2)\\1|(?:\\1\\2){2})\\b', 'g')
const str = `#EEEEEE
#AAA
#EFE
#333333
#00006d
#123456
#ABABAB`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}