# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([aeiouyAEIOUY]+[^e.\s])|([aiouyAEIOUY]+\b)|(\b[^aeiouy0-9.']+e\b)//mg;t' <<< "Hello my name is slim shady.Searching for syllables in a sentence. I hope this regex. works as supposed for 99%. Just, one more test he and she also works as supposed. "