$re = '/([aeiouyAEIOUY]+[^e.\s])|([aiouyAEIOUY]+\b)|(\b[^aeiouy0-9.\']+e\b)/m';
$str = 'Hello my name is slim shady.Searching for syllables in a sentence. I hope this regex. works as supposed for 99%. Just, one more test he and she also works as supposed.  ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;