use strict;
my $str = 'Hello my name is slim shady.Searching for syllables in a sentence. I hope this regex. works as supposed for 99%. Just, one more test he and she also works as supposed. ';
my $regex = qr/([aeiouyAEIOUY]+[^e.\s])|([aiouyAEIOUY]+\b)|(\b[^aeiouy0-9.']+e\b)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";