const regex = /([aeiouyAEIOUY]+[^e.\s])|([aiouyAEIOUY]+\b)|(\b[^aeiouy0-9.']+e\b)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([aeiouyAEIOUY]+[^e.\\s])|([aiouyAEIOUY]+\\b)|(\\b[^aeiouy0-9.\']+e\\b)', 'mg')
const str = `Hello my name is slim shady.Searching for syllables in a sentence. I hope this regex. works as supposed for 99%. Just, one more test he and she also works as supposed. `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);