using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/[^/\d\s]+(\d+)\.[^/]+$";
string input = @"/path/to/file/abc123/GCAM5423.xmp
/path/to/file/abc123/GCAM5423.cr2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}