const regex = new RegExp('\\/[^/\\d\\s]+(\\d+)\\.[^/]+$', 'gm')
const str = `/path/to/file/abc123/GCAM5423.xmp
/path/to/file/abc123/GCAM5423.cr2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}