package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/[^/\d\s]+(\d+)\.[^/]+$`)
var str = `/path/to/file/abc123/GCAM5423.xmp
/path/to/file/abc123/GCAM5423.cr2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}