$re = '/\/[^/\d\s]+(\d+)\.[^/]+$/m';
$str = '/path/to/file/abc123/GCAM5423.xmp
/path/to/file/abc123/GCAM5423.cr2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);