using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4})-(\d{2})-(\d{1,2}) (\d{2}):(\d{2}):(\d{2}).(\d{3})";
string substitution = @"Year: $1 Month: $2 Day: $3 Hour: $4 Minutes: $5 Seconds: $6 Millis: $7";
string input = @"2021-08-21 16:21:00.000
2021-08-1 16:21:00.000
2021-08-8 16:21:00.000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}