import Foundation
let pattern = #"(\d{4})-(\d{2})-(\d{1,2}) (\d{2}):(\d{2}):(\d{2}).(\d{3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2021-08-21 16:21:00.000
2021-08-1 16:21:00.000
2021-08-8 16:21:00.000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Year: $1 Month: $2 Day: $3 Hour: $4 Minutes: $5 Seconds: $6 Millis: $7"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)