const regex = /(\d{4})-(\d{2})-(\d{1,2}) (\d{2}):(\d{2}):(\d{2}).(\d{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})-(\\d{2})-(\\d{1,2}) (\\d{2}):(\\d{2}):(\\d{2}).(\\d{3})', 'gm')
const str = `2021-08-21 16:21:00.000
2021-08-1 16:21:00.000
2021-08-8 16:21:00.000`;
const subst = `Year: $1 Month: $2 Day: $3 Hour: $4 Minutes: $5 Seconds: $6 Millis: $7`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);