#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\bprocesstest\b"
Local $sString = "This is ProCeSSTesT or processTester or PROCESSTEST. processTeStprocessTeSt" & @CRLF & _
"" & @CRLF & _
"PROCESStest. This is ProCeSSTesT processtest processtest or processTester or PROCESSTEST. This is FooBAR or martyMCfly or foobAr and DummyFooBar PROCESStest"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")