using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bprocesstest\b";
string input = @"This is ProCeSSTesT or processTester or PROCESSTEST. processTeStprocessTeSt
PROCESStest. This is ProCeSSTesT processtest processtest or processTester or PROCESSTEST. This is FooBAR or martyMCfly or foobAr and DummyFooBar PROCESStest";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}