$re = '/\bprocesstest\b/im';
$str = 'This is ProCeSSTesT or processTester or PROCESSTEST. processTeStprocessTeSt
PROCESStest. This is ProCeSSTesT processtest processtest or processTester or PROCESSTEST. This is FooBAR or martyMCfly or foobAr and DummyFooBar PROCESStest';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);