const regex = /\bprocesstest\b/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bprocesstest\\b', 'gim')
const str = `This is ProCeSSTesT or processTester or PROCESSTEST. processTeStprocessTeSt
PROCESStest. This is ProCeSSTesT processtest processtest or processTester or PROCESSTEST. This is FooBAR or martyMCfly or foobAr and DummyFooBar PROCESStest`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}