#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:([a-zA-Z]+)(?=[^a-zA-Z]+|$)|(\d+)(?=[^\d]+|$))"
Local $sString = "1a1 a1a sd435 a gar ad ha5y a456 a45 afg adfgadfg adfg45 a5 a gh a56456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")