const regex = /(?:([a-zA-Z]+)(?=[^a-zA-Z]+|$)|(\d+)(?=[^\d]+|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([a-zA-Z]+)(?=[^a-zA-Z]+|$)|(\\d+)(?=[^\\d]+|$))', 'g')
const str = `1a1 a1a sd435 a gar ad ha5y a456 a45 afg adfgadfg adfg45 a5 a gh a56456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}