using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:([a-zA-Z]+)(?=[^a-zA-Z]+|$)|(\d+)(?=[^\d]+|$))";
string input = @"1a1 a1a sd435 a gar ad ha5y a456 a45 afg adfgadfg adfg45 a5 a gh a56456";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}