using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9xX?+^#!*\\[\]-]";
string input = @"+49 8161 40551
+49++ ?8161? 40551?[ [[]]]]]xxX???++++-----****^^^####!xX€[€¶]¶oqowoeijcop\\\\\\\";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}