re = /[^0-9xX?+^#!*\\[\]-]/
str = '+49 8161 40551
+49++ ?8161? 40551?[ [[]]]]]xxX???++++-----****^^^####!xX€[€¶]¶oqowoeijcop\\\\\\\\\\\\\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end