package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^0-9xX?+^#!*\\[\]-]`)
var str = `+49 8161 40551
+49++ ?8161? 40551?[ [[]]]]]xxX???++++-----****^^^####!xX€[€¶]¶oqowoeijcop\\\\\\\`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}