$re = '/[^0-9xX?+^#!*\\\\[\]-]/';
$str = '+49 8161 40551
+49++ ?8161? 40551?[ [[]]]]]xxX???++++-----****^^^####!xX€[€¶]¶oqowoeijcop\\\\\\\\\\\\\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);