import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(['\"])([^'\"\\s]*that\\.dude\\.js\\/v1[^\"'\\s]*)\\1";
final String string = "var a ='abc'; var b = 'http://a/that.dude.js/v1/'; var c = 'def'; var d = 'https://b/that.dude.js/v1/';\n"
+ "var basePath = \"http://othersite/that.dude.js/v1/\";\n"
+ "var a=angular.module(\"mtaWebApp\"),b=\"that.dude.js/v1/\",c=\"1.0.6\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}