re = /(['"])([^'"\s]*that\.dude\.js\/v1[^"'\s]*)\1/
str = 'var a =\'abc\'; var b = \'http://a/that.dude.js/v1/\'; var c = \'def\'; var d = \'https://b/that.dude.js/v1/\';
var basePath = "http://othersite/that.dude.js/v1/";
var a=angular.module("mtaWebApp"),b="that.dude.js/v1/",c="1.0.6";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end