$re = '/([\'"])([^\'"\s]*that\.dude\.js\/v1[^"\'\s]*)\1/';
$str = 'var a =\'abc\'; var b = \'http://a/that.dude.js/v1/\'; var c = \'def\'; var d = \'https://b/that.dude.js/v1/\';
var basePath = "http://othersite/that.dude.js/v1/";
var a=angular.module("mtaWebApp"),b="that.dude.js/v1/",c="1.0.6";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);