const regex = /(['"])([^'"\s]*that\.dude\.js\/v1[^"'\s]*)\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\'"])([^\'"\\s]*that\\.dude\\.js\\\/v1[^"\'\\s]*)\\1', 'g')
const str = `var a ='abc'; var b = 'http://a/that.dude.js/v1/'; var c = 'def'; var d = 'https://b/that.dude.js/v1/';
var basePath = "http://othersite/that.dude.js/v1/";
var a=angular.module("mtaWebApp"),b="that.dude.js/v1/",c="1.0.6";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}