using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(A)(5|8)(F|M|G|C)(2|3)(0|2)((-)(A|B|C|D|E|F|G){4,4}){3,3}";
string input = @"A8F30-ABCD-EFGG-AAAA
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}