import re
regex = re.compile(r"(A)(5|8)(F|M|G|C)(2|3)(0|2)((-)(A|B|C|D|E|F|G){4,4}){3,3}", flags=re.MULTILINE)
test_str = ("A8F30-ABCD-EFGG-AAAA\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")