const regex = /(A)(5|8)(F|M|G|C)(2|3)(0|2)((-)(A|B|C|D|E|F|G){4,4}){3,3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(A)(5|8)(F|M|G|C)(2|3)(0|2)((-)(A|B|C|D|E|F|G){4,4}){3,3}', 'gm')
const str = `A8F30-ABCD-EFGG-AAAA
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}