re = /(A)(5|8)(F|M|G|C)(2|3)(0|2)((-)(A|B|C|D|E|F|G){4,4}){3,3}/m
str = 'A8F30-ABCD-EFGG-AAAA
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end