use strict;
my $str = 'http://www.youtube.com/watch?v=a4tU7tkl6n8
https://www.youtube.com/watch?v=a4tU7tkl6n8&autoplay=1
https://www.youtube.com/watch?t=12&v=a4tU7tkl6n8&autoplay=1
https://youtu.be/a4tU7tkl6n8
https://www.youtube-nocookie.com/embed/a4tU7tkl6n8
https://www.youtube.com/embed/a4tU7tkl6n8
https://www.youtube.com/embed/a4tU7tkl6n8?autoplay=1';
my $regex = qr/http(?:s?):\/\/(?:www\.)?youtu(?:be\.com\/watch\?v=|\.be\/|.*\&v\=|.*\/embed\/)([\w\-]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}