import re
regex = re.compile(r"http(?:s?):\/\/(?:www\.)?youtu(?:be\.com\/watch\?v=|\.be\/|.*\&v\=|.*\/embed\/)([\w\-]+)", flags=re.MULTILINE)
test_str = ("http://www.youtube.com/watch?v=a4tU7tkl6n8\n"
"https://www.youtube.com/watch?v=a4tU7tkl6n8&autoplay=1\n"
"https://www.youtube.com/watch?t=12&v=a4tU7tkl6n8&autoplay=1\n"
"https://youtu.be/a4tU7tkl6n8\n"
"https://www.youtube-nocookie.com/embed/a4tU7tkl6n8\n"
"https://www.youtube.com/embed/a4tU7tkl6n8\n"
"https://www.youtube.com/embed/a4tU7tkl6n8?autoplay=1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")