re = /http(?:s?):\/\/(?:www\.)?youtu(?:be\.com\/watch\?v=|\.be\/|.*\&v\=|.*\/embed\/)([\w\-]+)/m
str = 'http://www.youtube.com/watch?v=a4tU7tkl6n8
https://www.youtube.com/watch?v=a4tU7tkl6n8&autoplay=1
https://www.youtube.com/watch?t=12&v=a4tU7tkl6n8&autoplay=1
https://youtu.be/a4tU7tkl6n8
https://www.youtube-nocookie.com/embed/a4tU7tkl6n8
https://www.youtube.com/embed/a4tU7tkl6n8
https://www.youtube.com/embed/a4tU7tkl6n8?autoplay=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end