#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\bis\b)?((?:(?!\bis\b)(?:What\s+is\b)?.?)+)"
Local $sString = "is What is this and Who is this What is cool What isisisis is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is is is is this what is What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")